This project is read-only.

No entry on Right Click Menu

Apr 9, 2011 at 10:35 AM


I have installed your extension and rebooted but still do not get an entry on my right click menu.

VS2010 Ultimate

Windows 7 Ultimate 64 bit




Apr 9, 2011 at 11:45 AM

Did you remember to install the 64 bit version? And what tool are you using when right clicking. Windows Explorer?

Apr 9, 2011 at 3:16 PM

I didn't realise there was one, i just clicked on the download link on home page.

Found correct download now and that has fixed it,



Jul 29, 2011 at 2:26 PM


I am not getting the right click menu option, although it was working until few days ago when it mysteriously disappeared. The only action I took before was changing the default program for .sln files from Visual Studio Version Selector to Visual Studio 2010. Reinstalled and repaired several times with 64 bit version, repaired and also tried it with 32 bit version. Rebooted after each action.

Windows 7 Enterprise 64 bit

VS 2010 Professional



Jul 29, 2011 at 9:42 PM

Hi Martin,

I am wondering:

1. If you change the default program for .sln files back to "Visual Studio Version Selector" does it work again?

2. Can you manually run msbuild.exe on the sln file?

This will allow us to determine if the contents of the msbuild file is still in a valid format and compatible.

3. Does HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.sln\OpenWithProgids exist and have a registry value (REG_NONE) with the name "MSBuildShellEx"?

Thank you.

Aug 1, 2011 at 12:35 PM
Edited Aug 1, 2011 at 3:26 PM

Hi Icnocop,

I did change the default program back but it didn't work. After PC reboot, the right click menu option was still not there.

I have just manually cleaned, built and rebuilt some solutions and msbuild itself seems to work correctly.

I checked the registry and this is what I have found out: OpenWithProgids entry exists and has registry with value (REG_NONE), but it's name is "VisualStudio.Launcher.sln" and data field empty. I have manually deleted this registry value and ran the MSBuildShellEx repair, but it only added the same value again, i.e. with name "VisualStudio.Launcher.sln". I wanted to add reg. value with name "MSBuildShellEx" manually, but REG_NONE type is not available in the list of types.

And so my guess is it might have something to do with registry...

Edit: my colleague has also entry with "VisualStudio.Launcher.sln" but it works for him.


Aug 2, 2011 at 7:52 AM

Hi Martin,

I believe "VisualStudio.Launcher.sln" is ok.  I have that on one of my machines as well and msbuildshellex is working without issues.

If you download the latest msbuildshellex source code and right-click on the "MSBuildShellExtension.sln" file from the trunk, it should display the MSBuild context menu.

Do you get the context menu if you right-click on "MSBuildShellExtension.sln"?

Do you and your colleague have the exact same sln file (no modifications)?

It works for me: Windows 7 Ultimate x64 SP1, Visual Studio 2008 Team System, Visual Studio 2010 Ultimate, MSBuildShellEx 64-bit (but Visual Studio is not a requirement).

Also, are there any relevant errors in the Windows Event Log?

I am also wondering if you can list any other programs you have installed?  Are any programs another type of windows shell extension?

Maybe your anti-virus is blocking the shell extension for some reason, so you may want to disable it during installation and\or when you try to right-click on a sln file.

You can also download ShellExView ( to see if "PerformanceDude.MSBuildShellExtension.ContextMenu" is registered and enabled on your system.

If it still does not work, maybe we can setup a remote connection and I can help troubleshoot the issue.

Thank you.

Sep 1, 2011 at 4:14 AM

Hi Martin,

Any updates on the issue?

I am wondering if you can try the following:

1. Uninstall "MSBuild Shell Extension" from "Programs and Features"

2. Delete "C:\Program Files\MSBuildShellExtension" (You may need to reboot your machine in order to do this if the msbuild shell extension was previously loaded from a right-click in windows explorer for example.)

3. Install the MSBuild Shell Extension v2.1 64-bit setup installer.

4. Try again.

Thank you.

Sep 2, 2011 at 8:32 AM

Hi Icnocop,

I have already given up and uninstalled it ages ago, decided to live without it. After your recent post, I have decided to try again, have checked "C:\Program Files\MSBuildShellExtension" didn't exist and as I reboot my PC several times a week anyway, I simply installed it again. Now I have the context menu again and I was able to build one of my solutions.

I have no idea what has changed that makes it work again, but if I'll ever find out, I'll make sure to post it here. Thank you for your support.


Oct 16, 2012 at 2:07 PM

Hi everyone,


Like ElWin00, I have the same issue :

I've installed the framwork 4.5, uninstall the v1.2, restart and then install the v 2.1( with the latest version is the same), but it won't work, can you guys could give me an advise ?



Oct 19, 2012 at 7:23 AM

MSBuild Shell Extension doesn't support .NET 4.5 (yet). What exactly is your problem? Is the MSBuild menu not visible or doesn't the build work?